切换到宽版
  • 984阅读
  • 9回复

CNC数月不用,想用时却出问题,还是疑难杂症!!! [复制链接]

上一主题 下一主题
离线cdcdcd
 

发帖
333
M币
1473
专家
6
粉丝
26
此悬赏帖已过期
最佳答案:50 M币,热心助人剩余点数: 7 M币。
4060雕刻机(1605滚珠丝杆副3根、Y轴30光轴4根、X轴30光轴2根、Z轴30光轴2根),TB6560并口一体接口板控制板驱动板,X31做主机(BIOS关电源省电、降频),500W环形变压器提供30V主电源、12V及5V独立三路,软件MACH3,所有轴润滑良好无间隙,滑动顺畅无噪音,57大扭矩2.4牛米步进电机,联轴器无松动,设置8细分(原16细分)、25%快衰减、3A、自动半流,MACH3内核25000(原设置75000),电机调试内所有轴同:脉冲数320、最大速度1500、加速度200(原脉冲数640、最大速度2500、加速度280)2KW变频器+2KW水冷主轴。

几个月未用,最近想加工点东西,突然发现铣个孔都是转弯的
数天多次下手无果,丛原设置到现设置均一样。
仔细观察下发现X、Z轴一切正常不跑不偏,加工多少数值就是多少数值。
Y轴却是根据F值的大小变化(F值大就变大,F值小就变小),在MACH3设置页校准Y轴输入500mm机器移动测量565mm输入后自动改变X轴脉冲数(约280.XXXX),然后手动编程页输入G0 Y550后测量仍然是550mm,当输入G1 Y550 F300后测量不足500mm,再从新对齐起点后输入G1 Y550 F1500后测量是556mm,再从新对齐起点后再改变F值为200%输入G1 Y550 F1500后测量达到583mm。


测试期间拆除了变频器接线、主轴接线、0-10V控制线,且切断主轴相关电源,机器可靠接地控制器也在全封闭铁盒内无干扰,所有接线为硅胶特软线线头均打了欧式紫铜管型端子,所有管型端子均有接线端子压接连接,比航空插头可靠几百倍。


IBM X31已重装3次系统,ghost纯净版XP、ghost纯净版2000高级服务器版、光盘安装版原生XP。
驱动也Y和Z调换、X和Y调换,3天内反复重装、调换、设置均是Y轴大小变化。

有人遇到过这样的情况吗?目前没有换电脑试过,已经买了一台戴尔OptiPlex 960机器要3天后才能测试
本帖最近打赏记录:共1条打赏M币+30
守护者 M币 +30 帮楼主回血,我表示不知道这种情况,还有就是我怎么可以打赏200M币了。。 06-10
离线守护者
发帖
13
M币
281
专家
0
粉丝
0
只看该作者 1楼 发表于: 06-10
热心助人奖励:+1 M币
帮楼主回血,我表示不知道这种情况,还有就是我怎么可以打赏200M币了。。
离线hky9075

发帖
724
M币
2437
专家
3
粉丝
65
只看该作者 2楼 发表于: 06-11
热心助人奖励:+1 M币
类似的情况我遇到过,但是我的比你的复杂,一般的雕刻机问题都是伸手党,实在是懒得看,楼主这个确实是疑难杂症。
我也是mach3,台达ASDA-B2伺服,我的mach3最大输出频率是2MHz,但是是单端信号,台达伺服单端信号输入最高只支持500KHz。所以我费了挺大劲设计制作了一个单端转差分的电路,还是用的高速差分运放,来转换这个信号,电路是搞成了,示波器也上了,看起来没问题,但是加工东西的时候就会发现Z轴不断的缓慢向下扎……直到铣了台面我才发现……
后来我再用示波器比对差分放大器前后的波形,发现单端信号的一些小的干扰和杂波会被放大成差分信号,引起伺服电机动作。
楼主的这种情况,我建议如下排查手段:

二,对调X和Y驱动器的脉冲信号线,看故障的轴是否变化,
不变化,基本确定是步进电机过冲,可能是负载惯量过大,减小加速度设置,增加驱动器电流,或者取消自动半流,设置为全流锁止(恐怕会发热比较大)。
变化,基本确定是步进电机驱动器故障,或者是mach3接口板故障。这种情况一般是驱动器的问题多一些,接着看下面:
保持X信号控制X电机,Y同理,对调X和Y两个驱动器,观察故障轴是否变化
变化,锁定故障在驱动器。更换应该可以解决。
不变化,故障在mach3接口板的可能性比较大,步进电机几乎没可能会出现这种故障……
顺便,TB6560的参数简直惨不忍睹,换换吧
离线春风舞柳

发帖
2271
M币
6016
专家
0
粉丝
11
只看该作者 3楼 发表于: 06-11
热心助人奖励:+1 M币
3楼说的靠谱  故障在mach3接口板的可能性比较大
离线youye1123

发帖
1241
M币
371
专家
0
粉丝
25
只看该作者 4楼 发表于: 06-10
还没遇到过这种问题,我的2030数控雕刻机也快一年没有使用了,回头也赶紧试试
离线cdcdcd

发帖
333
M币
1473
专家
6
粉丝
26
只看该作者 5楼 发表于: 06-11
回 hky9075 的帖子
hky9075:类似的情况我遇到过,但是我的比你的复杂,一般的雕刻机问题都是伸手党,实在是懒得看,楼主这个确实是疑难杂症。
我也是mach3,台达ASDA-B2伺服,我的mach3最大输出频率是2MHz,但是是单端信号,台达伺服单端信号输入最高只支持500KHz。所以我费了挺大劲设计制作了一个单端转差分 .. (2017-06-11 01:34) 回 hky9075 的帖子

驱动器对调过症状一样
离线cdcdcd

发帖
333
M币
1473
专家
6
粉丝
26
只看该作者 6楼 发表于: 06-11
换了一套OK了,现在声音已经非常小了,是TB6600改进版那种,锁止时还有电流噪音,这东西居然没有快慢衰减的调整。

手里还有5套雷塞DM432C驱动器,啥时候换上试试应该绝对静音,目前驱动多摩川42步进电机没有任何震动和噪音,电机转不转都听不出来的,拿在手里就像是冯哈勃的空心杯电机一样静音,最大能上3A应该改能驱动57的电机
本文内容包含图片或附件,获取更多资讯,请 登录 后查看;或者 注册 成为会员获得更多权限
离线青色风机

发帖
17016
M币
18731
专家
24
粉丝
1551
只看该作者 7楼 发表于: 06-12
太专业啦,我来学习学习
离线wxg263

发帖
240
M币
-245
专家
1
粉丝
1
只看该作者 8楼 发表于: 06-12
厉害了,我的一直有是链接线有问题 查了好久查查出来
离线cdcdcd

发帖
333
M币
1473
专家
6
粉丝
26
只看该作者 9楼 发表于: 06-13
回 wxg263 的帖子
wxg263:厉害了,我的一直有是链接线有问题 查了好久查查出来 (2017-06-12 21:32) 回 wxg263 的帖子

这是几个意思?
快速回复
限80 字节
“新手上路”发帖需审核后才能显示(请认真发帖),达到数码9级后取消此限制
 
上一个 下一个