切换到宽版
  • 1110阅读
  • 15回复

路由器电源的维修 [复制链接]

上一主题 下一主题
离线panbangwen
 

发帖
511
M币
129
专家
3
粉丝
17
家里的路由器突然罢工了,发现路由器上的LED灯都不亮了,应该是电源坏了。用万用表一测,果不其然,没有输出了。
本着死马当活马医的精神,将电源锯开两半(电源的外壳是粘合的,只能暴力打开了),看看能不能修复。
电源的做工还不错,不是那种简单的单管自激,EMI也很齐备,用料也算精良,而且这么小的体积就有12V/2A的输出,应该算得上是个好电源,值得维修。






凭着还有29年就有30年的维修经验,感觉是输出端的两个滤波电容(470μF/16V)失效了,但是外观看起来却是好好的,看不到开裂,也没有鼓包。两个470μF/16V是并联使用的,而且还有π形滤波,说明这个电源的品质还是不错的。
不管三七二十一,先焊下来再说,拆下来之后,引脚太短插不进万用表测量,就用两个插针焊在引脚上延长。延长后用电容档测量,标称470μF的电容只有3.3μF,电源不能正常工作也在情理之中了。




但是手头没有470μF的电容,怎么办?笔者想到了报废的坏主板。笔者拿出了珍藏了几十年的坏主板,发现主板上确实有很多470μF的电容。


主板电容不怎么好拆,只好在两个引脚上堆锡,堆满锡之后,就比较好拔下来了。
换上一只主板电容后,通电试试,已经恢复12V输出了,证实了笔者的判断是正确的,将另一只从主板拆下来的电容也焊上去,电源已经完全恢复青春了,用电工胶布将外壳包起来,我的路由器又可以愉快地工作了。
本文内容包含图片或附件,获取更多资讯,请 登录 后查看;或者 注册 成为会员获得更多权限
本帖最近打赏记录:共3条打赏M币+54
温力口 M币 +9 谢谢分享。。。。。 01-09
rkit M币 +15 謝謝分享 01-09
sunnyquan M币 +30 很好的经验分享,图片清楚给力! 01-09
离线sunnyquan

发帖
2971
M币
3568
专家
6
粉丝
15
只看该作者 1楼 发表于: 01-09
很好的经验分享,图片清楚给力!
离线289867249

发帖
803
M币
170
专家
1
粉丝
19
只看该作者 2楼 发表于: 01-09
水贴么!次级电容失效不会造成无输出只是波纹变大啊!电容短路的话倒是会造成无输出但一会电容就爆浆了啊!
离线摸心拿肝

发帖
712
M币
2001
专家
3
粉丝
36
只看该作者 3楼 发表于: 01-09
用20uF档测量470uF的电容?
离线tzl7278

发帖
11570
M币
10162
专家
10
粉丝
87
只看该作者 4楼 发表于: 01-09
回 289867249 的帖子
289867249:水贴么!次级电容失效不会造成无输出只是波纹变大啊!电容短路的话倒是会造成无输出但一会电容就爆浆了啊! (2019-01-09 09:55) 回 289867249 的帖子

笔者想到了报废的坏主板。笔者拿出了珍藏了几十年的坏主板,发现主板上确实有很多470μF的电容。

证实了笔者的判断是正确的,将另一只从主板拆下来的电容也焊上去,电源已经完全恢复青春了,用电工胶布将外壳包起来,的路由器又可以愉快地工作了。


看着确像剪贴的。
离线fengwx2008fe

发帖
805
M币
424
专家
0
粉丝
6
只看该作者 5楼 发表于: 01-09
路由器的用不到2A吧
离线panbangwen

发帖
511
M币
129
专家
3
粉丝
17
只看该作者 6楼 发表于: 01-09
回 289867249 的帖子
289867249:水贴么!次级电容失效不会造成无输出只是波纹变大啊!电容短路的话倒是会造成无输出但一会电容就爆浆了啊! (2019-01-09 09:55) 回 289867249 的帖子

这只能说你是想当然罢了,你的说法在传统工频变压器上是成立的,实际情况就是换了电容之后就好了。
离线panbangwen

发帖
511
M币
129
专家
3
粉丝
17
只看该作者 7楼 发表于: 01-09
回 tzl7278 的帖子
tzl7278:笔者想到了报废的坏主板。笔者拿出了珍藏了几十年的坏主板,发现主板上确实有很多470μF的电容。
证实了笔者的判断是正确的,将另一只从主板拆下来的电容也焊上去,电源已经完全恢复青春了,用电工胶布将外壳包起来,我的路由器又可以愉快地工作了。
....... (2019-01-09 10:19) 回 tzl7278 的帖子

每只字都是我亲手码出来。
离线panbangwen

发帖
511
M币
129
专家
3
粉丝
17
只看该作者 8楼 发表于: 01-09
回 摸心拿肝 的帖子
摸心拿肝:用20uF档测量470uF的电容?[表情]  (2019-01-09 09:56) 回 摸心拿肝 的帖子

如果电容已经失效,用低量程来判断就可以了。
本帖最近打赏记录:共1条打赏M币+8
摸心拿肝 M币 +8 謝謝分享 01-10
离线abit

发帖
1708
M币
4472
专家
2
粉丝
16
只看该作者 9楼 发表于: 01-09
回 289867249 的帖子
289867249:水贴么!次级电容失效不会造成无输出只是波纹变大啊!电容短路的话倒是会造成无输出但一会电容就爆浆了啊! (2019-01-09 09:55) 回 289867249 的帖子

电容失效,或者说容量低了,都会造成设备不能正常工作,如不断闪烁,甚至直接不亮的。我就遇到过了,公司的监控主机,大华的,电源外置,是12V5A的,发现监控主机不亮,换另一个适配器就好了,然后拆开,末端电容两个16V 1500uf 电容鼓起,万能表测了还是有输出,但是,达不到监控主机的工作电流电压要求,所以设备不启动。
所以楼主那个应该还有输出的,但是是达不到路由器的供电要求,所以路由器灯不亮。


另外就是楼主图片没有放好对应的位置,重复了。
很懒的diyer,还是一个宏碁!