切换到宽版
  • 5919阅读
  • 17回复

解决:SMI主控量产后,在AMI UEFI/BIOS下不能识别USB-HDD(原创) [复制链接]

上一主题 下一主题
离线wuwuzz
 

发帖
1253
M币
4769
专家
45
粉丝
56
只看楼主 倒序阅读 我要置顶 楼主  发表于: 2015-12-05

SMI主控量产后,在AMI UEFI/BIOS下不能很好地识别多驱,
也就谈不上USB-HDD启动成功。已经有好几个帖子报告这种现象:

慧荣量产后,制作成双启动(USBCDROM+USBHDD) 无法在AMI UEFI中识别USBHDD分区
http://bbs.mydigit.cn/read.php?tid=729963

SMI SM3267ABS 量產三區三啟BIOS下偵測不到USB-HDD
http://bbs.mydigit.cn/read.php?tid=1298092
http://bbs.mydigit.cn/read.php?tid=1302697

----------------------------------------------------------------------
出现问题的理论原因,我已经悟出来了,比较蛋疼。现尝试提出解决方案:

SMI主控量产时,默认VID/PID为090C/1000,把它们全改掉。
即:VID不能为090C,PID不能为1000。
当然,只改某一个,也可能成功,但为了保险起见,还是2个都改了吧。


有这种问题的同学,自己实测,无论成不成,把结果报上来。


本帖最近打赏记录:共8条打赏M币+73专家+1
关键词: SMIUEFIBIOSUSB-HDD
离线wuwuzz

发帖
1253
M币
4769
专家
45
粉丝
56
只看该作者 1楼 发表于: 2015-12-05
二楼先占位待用。待实测报告上来后,届时论坛设置
如允许修改本楼内容,我将在这里解释原因。

先透个风,这种问题,本来累死也找不到原因的。
但是,由于AMI UEFI源代码泄露了( http://bbs.mydigit.cn/read.php?tid=567739)
所以,解决问题的机会来了--如果你学习了源代码,并且有悟性的话...。
离线恒鑫电子

发帖
3308
M币
8302
专家
1
粉丝
18
只看该作者 2楼 发表于: 2015-12-05
路过,我小白一个,帮顶
离线w137757869

发帖
454
M币
2546
专家
2
粉丝
12
只看该作者 3楼 发表于: 2015-12-08
此主控U盘我有两个,一个16g ,一个32g,PID VID随便改吗?
离线fingerskps
发帖
263
M币
601
专家
3
粉丝
12
只看该作者 4楼 发表于: 2015-12-08
我是wuwuzz的好友,现在他在外地学习,不方便上网。
代其回答:vid,pid随便改。最好vid,pid2个值都改掉。

ami bios/uefi下的这个问题与容量无关。
离线stdzlqz

发帖
2469
M币
10039
专家
23
粉丝
199
只看该作者 5楼 发表于: 2015-12-21
改过之后,在H81正常双起,以前是不行的,确实蛋疼的问题。
本帖最近打赏记录:共3条打赏M币+9
离线wuwuzz

发帖
1253
M币
4769
专家
45
粉丝
56
只看该作者 6楼 发表于: 2015-12-22
辛苦了! 您的报告我们非常需要,也是我们深入研究的动力。论坛的评分机制改了,要不然,应该再多加M币的。
离线wuwuzz

发帖
1253
M币
4769
专家
45
粉丝
56
只看该作者 7楼 发表于: 2015-12-22
无忧成功案例:
http://bbs.wuyou.net/forum.php?mod=viewthread&tid=373397
第7楼ddzjd439的报告。
离线红毛樱木

发帖
904
M币
1950
专家
4
粉丝
28
只看该作者 8楼 发表于: 2015-12-22

老大,这个和LUN有关吗?
离线wuwuzz

发帖
1253
M币
4769
专家
45
粉丝
56
只看该作者 9楼 发表于: 2015-12-22
回 红毛樱木 的帖子
红毛樱木:
老大,这个和LUN有关吗? 回 红毛樱木 的帖子


我不是老大,是新兵。
是的,与LUN有关。AMI UEFI/BIOS对多LUN支持 有失误。